Onyx RC 4.9.1257


Hi Everyone,

This build requires OS 4.9 to be installed first on consoles.

As always, please keep all discussions and comments about this beta to THIS forum post.

Happy testing!!

4.9.1257 (15/11/2023)

  • Enabled palettes in effect slots and masks
  • Direct Telnet commands now support point cues
  • Fixed DMX input merging while cross fading
  • Fixed “Once” playback mode (running beyond last frame)

Update issue on previous beta version where is you have 2 effect depending on the source with the second one with a opacity that lets thru the first effect the second effect will be darker

unless you add brightness to the first effect

Bug with letter and motion blur
when a letter has a bounce animation with motion blur one side work ok but when it returns in the middle of the canva the motion blur flips the other way instantly

would be nice to have the control if the letter animation loops directly or has a pause. RN it has a long pause to its weird using it with effect when it stops directly for half a second

Question 1:Where do I find UDP comands in the manual?

Question 2: Seems I am not able to make the UDP packets work in this version, I am working on the same PC ,does " Telnet" need a license?

hi Giancarlo
Look help on line: Telnet and UDP Commands (obsidiancontrol.com)
All commands are online

I did an in place upgrade on two computers and my NX DMX no longer works properly. I am in the middle of a show, so I haven’t tried a clean install yet. But I tried updating the firmware, which I did the same version of firmware, in case that was remotely an issue. I tried it from both computers and it doesn’t work. Two older DMX interfaces still work, the silver metal one and the grey plastic one.

Hello, there should be no reason for the NX DMX not to work. You mention you could access it through firmware update, so hardware, firmware and drivers appear ok. What doesn’t work then? Does it show up in the “DMX Settings” menu? Is it still configured properly?

Yes, when I installed over the previous version without uninstalling the drivers or uninstalling Onyx, that’s when the USB DMX devices had problems. It appeared okay within Onyx software itself but the DMX output was not good. On a third computer I had the same problem with the grey plastic USB interface worked at first and then had problems. The lights started acting strange, as if there were data reflections in the line, & then DMX stopped responding and weird behavior from the lights.

When I did a clean install, by uninstalling Onyx, uninstalling the Onyx drivers first, then restarting the computers and reinstalling Onyx drivers and Onyx, then I didn’t notice any problems.

Hey @obsidiancontrol ,

I reported a bug for .1256 via Obsidian support last week, and received a reply this evening asking me to post it in the forum instead. Given that the discussion for .1256 is locked, I’m writing it here instead. I have not had an opportunity to validate if this has been addressed in .1257, but I can confirm that it’s been an issue on several .1256 shooflies on PC, several NX1’s, and an NX4. Please see details below –

If the console’s “Global Fade” is set to a low value (i.e: 30%) and a Chase is running, tapping-in a new BPM on the chase via “Go” results in the Chase setting an erroneous BPM value in-the-millions. This immediately causes a crash of the entire playback & program engine without an error dialogue. DMX continues to output and the GUI is responsive, but no changes to playbacks or programmer values are output. This bug has been reproducible on several systems. The only way to restore normal operation is a hard power reboot of the console. Please refer to ticket #335293 for detailed screenshots, video, and a copy of an affected show file.


Hello, the new way to save preset by default, when you select the type of device to modify, and I pan/tilt it, the device does not move, that is, I have to exit edit mode, move it, see the values ​​that I want to capture, enter in edit mode and give them to them. Wouldn’t it be better if in edit mode you could see those values ​​working??? Another thing, in this mode when you move the encoder it jumps to value 0 instead of being at the current default value for example pan/tilt 50/50.

1 Like

Yesss! I absolutely agree. The new method, as implemented in the release candidates, is super impractical. I’ve resorted to creating a “default” cuelist with a low priority that I set to start at launch.

1 Like

I think its more easy and quick set up your fixture as u want as default and store in default button. Now u can t see what u re making… and i think is more uncomfortable work. Highlight works ok but at the end u need 3 buttons to set up your defaults ( default hihligh and offset) i think could be more easy have it as previus versions in “default” window

Hey @obsidiancontrol — is it possible to receive confirmation that this is being investigated?

Thanks for the report, this will be fixed in build 4.9.1258

Thanks for the report, this will be fixed at a later stage, though

Thanks for the report, we’ve been able to reproduce and are currently investigating the problem

Replaced with RC 4.9.1259