Onyx RC 4.9.1259

Hi Everyone,

This build requires OS 4.9 to be installed first on consoles. The OS and OS tool are in the download link.

As always, please keep all discussions, comments, and bug reports about this release candidate to THIS forum post.

Happy Holidays and Happy testing!!

Download: Replaced with 4.9.1262

4.9.1259 (20/12/2023)

  • Fixed crash while changing chase BPM when global rate is not at 100%
  • Fixed selecting fixture number(s) in the patch grid no longer putting ‘@’ on the command line
  • Fixed chases with faders at zero “blipping” their intensity on every step
  • Fixed transparent color blending in deformation effects
  • Fixed connection of playback go button to tap processor
  • Fixed software to fail when selecting a fixture range in reverse order, with the last fixture to be selected being the first one in the show
  • Fixed preset number indication (in parameter group tab) not updating on changes
  • Fixed double clicking fixture button in fixture center (for starting range selection) putting ‘@’ on the command line (preventing to continue range entry with keypad)

Facebook post asked if anyone else had trouble with the OSC. Replying here. Just installed. Only noticed that on one playbackI had to hit play before the name of the cuelist populated but when I switched banks it automatically populated the names. On the names of Overrides the names automatically populated.

MidiMacros crash the DMX Engine of Onyx 1257.

Windows 11 AutoUpdate
Asus Notebook i9 13gen, RTX 4060
Onyx 128 License
Korg nanoPad2

Midi Macros issues:

  • Assigning Note-off & on events will persist during a complete session even though they are deleted. Pressing the Midi device triggered the event after deletion nevertheless. Onyx must be restarted

  • Assigning four Note Events to two midi buttons crashed the engine.
    I assigned Go & Release (Note On / Note Off) to each button. No Cue could be triggered via Midi.
    Onyx back end processes crashed, taskmanager couldn’t help and I was forced to restart the computer.

  • After restarting the computer, the Midi assignments worked for two minutes. I triggered the assignments a couple of times during those two minutes. The activation became slower and slower until the Onyx Engine crashed again. No Cuelist could be started at this point. Not via Midi nor via Mouse&Keyboard.
    Onyx simply froze. I had to quit Onyx.

I can send you a video for reproduction purposes if it helps to fix it

My NX4 does not want to update.

I have 4.9.1248 installed.

I tried many times with the 1256 and now with the 1259 version.
Is it not right to use the .exe?

To use the .exe of 1259 it is my understanding that you have to have the console OS of 4.9.1252 already installed. They have that in the downloads folder with 1259.

Give that a try and see if you can install 4.9.1259 after that.

Hope this helps,


1 Like

Why if I change the “Alpha transition” on the fly also my "Mirror effect "is resetted ? it has no sense! because I need then to re do all again.

I am leaving the message because now it’s not doing it anymore! if someone else coud try that out,and see what happens it would be cool!

Hello, I am experiencing problems with NDI. I use Win10 computers and the showfile was opened and saved on two different machines in two different network environments.

My tranmitter is set up OK. On the receiving computer, I run NDI Tools’ Studio Monitor and the receiving works ok.

In Onyx, the receiving does not work. It did work previously but stopped. Today I changed the transmitter’s name and it started to work in Onyx right away. I did just one session with that working, so don’t know if it is gonna continue to work. It looks like the old nodes/streams in the Onyx showfile are somehow stuck and do not receive correctly.

Also there are unused old nodes still present, I would like to remove them, but don’t know how.



I can second this – I have regularly been using NDI with various VJ’s, and have no idea how to remove old nodes from my show file.

we have the same problem!

Get the same with NX1. But as written in the first message, there is a new iso to install firstly, then the update can be done (maybe some change done between last beta iso and this one)

do you think this will matter?

is that just creating a shortcut to the fixture editor?

All that property does is preventing that an icon for the library editor is added to the start menu (automatically), so it shouldn’t matter, but weird you’re getting this warning.

I tried many times with the 1256 and now with the 1259 version.

Hello guys,

Anybody is using Onyx’s RDM features?

I did a lot of testing and it seems to be really bad with RDM.

I’m using Onyx RC 4.9.1259 on a Windows Computer with an EP4 node and some nodes from C.I.Tronics (I’m the main developer of these nodes).

The EP4 works most of the time, although somewhat erratic and slow.

The devices connected to the C.I.Tronics nodes also are recognized in the samewhat erratic way. Although a little worse.

The C.I.Tronics nodes works well with GrandMA and DMX Workshop.

The EP4 works well with DMX Workshop. EP4 doesn’t work with GrandMA because of some non standard implementation on GrandMA.

The C.I.Tronics nodes implement some more aggressive RDM devices scanning (that can be disabled). This feature makes it work with GrandMA.

The problems I’m reffering here regard RDM communications. DMX works perfectly with EP4 and C.I.Tronics both by sACN and Art-Net on every piece of software I’ve tested.


Edson Brusque
Electrical Enginner
C.I.Tronics Lighting Designers LTDA

Is the EP4 on Release 2.94 ?

Got a product page for the nodes ? I’m not familiar with them.

CLU (obsidiancontrol.com)

Hello Matthias!

Yes, EP4 firmware is 2.94.

We still don’t have a page about these nodes. But I can give you more infos if you want.

I’m still doing tests and optimizations on our firmware. If I find a replicable issue I’ll let you.


I am leaving the message because now it’s not doing it anymore! if someone else coud try that out,and see what happens it would be cool!.

huh? this message makes no sense…
Try explaining your problem not just saying DNFW (does not fucking work)

Updated 2/10/2024 with edited comments

I’ve noticed issues with synchronization using two laptops, especially if switching the audio source from one laptop to the other. For example, when one laptop freezes up , upon switching to the other one needs to get the audio input working. It would be nice if there was a priority level for the source of the audio input and auto switching of the sources when one computer fails.

Beat detection on Chase is working well but if I set the BPM Center to less than 60 it freezes.

Using the Beat Divider, as suggested, is working after creating an audio input in Dylos and then a Beat Divider choosing that input.

In most laptops it’s only the WASAPI input that seems to work. Direct source sometimes works but the first option rarely.

Changing the settings live is noticeable. It doesn’t appear to respond to Live Time. It jumps when the setting is changed. Can’t use this for busking in smooth situations to adjust the responsiveness because it glitches every time you change the parameters, jumping to the new setting.

Please note that it’s calculating the BPM well but I wish it would “show the BPM”.

I’d like a smooth way to transition between levels in the settings. For example, if a Q-Blender is used, I’d like it to be smooth and not jump.

I’m trying to get more reaction from the beat rather than just the rate. And I’d like that to work better with more sensitive parts of a song.

What settings are aimed at the reactivity to beats / sounds rather than just the rate of the BPM?

Granted that this new feature is a work in progress.