Onyx RC 4.9.1262 (Final Review)

Hi Everyone!

We are reaching the end of this release candidate cycle and are preparing for the release of Onyx 4.10!

This is expected to be the last RC of the cycle before release, with that being said this is a critical RC to review and report any major issues found while testing.

As always, please keep all discussions, comments, and bug reports about this release candidate to THIS forum post.

Just a note; You must be running the 4.9 OS if installing on a console. Provided in the link below is the OS and OS tool.

Supported Consoles:

  • NX4
  • NX2
  • NX1
  • M6 (w/ Onyx upgrade kit)

This Beta has been closed.

Have a great weekend and Happy Testing!

4.9.1262 (22/02/2024)

Improved Reaper/CSV import (properly import timecode beyond 9h, preserve mark numbers if properly ordered, added support for single-dotted mark numbers, feedback on import issues)
Improved cloning fixtures into fixture groups that have a grouping mask
Fixed issues with multi-patched fixtures (P/T invert/swap, rotate)
Fixed issues with programming relative values (using encoders) into default/highlight/park values
Fixed “input” color picker mode in video processor

4.9.1261 (16/01/2024)

Workflow fixes and improvements for modifying default/highlight/park/offset values

4.9.1260 (27/12/2023)

Added possibility to merge programmer contents into default values from RECORD popup

1 Like

Where do you see quantity in the group button? I only see the group numbers, 1 and 2.

Yeah Matthias your completely right ? Sorry wrong software ,we do not have how many fixtures there are in a group.
I will delete It!

Ok so meanwhile we are having this nice discussion!
Request, do you think that kind of info could be "added " to our groups in future versions?

1 Like

Is the "internal Manual " working for you?
Her I was trying to see “record” but I always have this window!

Message is : Impossible to find file

Major bug…
You cant set the offset to be positive only in the negative

when you try setting it to a positive it resets to default in most cases.
for the stobe somehow it resets to -99% to fix it you can only clear the values
some gobos params also resets to -99 any offset set.

Tested with 10 mac 700 profiles


I can’t seem to replicate this issue. You are on version 4.9.1262? If so, can you send me the showfile?



After further testing we can reproduce the bug with the offsets.

Thx for reporting,


Went to install it on my Windows 11 PC. The prerequisites, and the uninstall of 4.8 from the ISO installed fine. When Onyx went to install it rolled back half way through and said “The installation was interrupted before ONYX could be completely installed. Please try again.” I rebooted several times, I removed the drivers and tried reinstall, I turned off all the firewall and anti-virus services. I also tried to install IIS and that did not work either. I am not able to complete the install. Thanks.

Also, I ran as Administrator and my own user Admin account. Neither worked.

Update: I removed all the IIS options from the OS and it was able to install. Must have been a permissions issue on one of the directories under the inetpub. I was getting an error when it failed that it could not delete a history file in there. It is installed now.


As a workaround until you get the fix, you can change the value ‘relative’ by clicking and holding the mouse in the ‘value’ region and dragging it up or down.


When using the default cue what also would be usefull , is to have the chance to set individual fade " timings "for each single parameter, if your asking why, to avoid strange behaviours.
Let’s suppose last fixtures that are fading out in your last cue have a colour white ,so when you release,what happens is that you will have a global release time, so in this case letting people see fixture that from colour white going to a congo colour!
Can you think about? THANX = )

There was an issue with the export that got built into the RC.

We have found and corrected the issue for the next build. :slight_smile:

Thanks Giancarlo!

Pleasure to help!

Just downloaded it today but can’t add or copy pages on the 2D plan view. Also cannot delete layers in 2D view as well. When you click on the button, nothing happens.

When using beat input source: Chase → Chase Options → Tap Sync Options → Enabled = Disabled is ignored.
Enabling the Chase will always Tap Tempo of Beat/Sound Trigger. Midi Trigger included.
Setting it to Toggle is a workaround for playback pads.

Before release, please complete the window size options for the new audio input popup windows.

We can’t resize them. I’d like to be able to make them smaller.


What window do you mean exactly? The one when you create a new (input) library item or the one that opens when you doubleclick (with the properties and the channels)?


1 Like

As we can’t duplicate this, is it possible to send us your showfile?


Sent the file to the support email.