Onyx Remote on iPhone

I am using a new Windows 10 install, with a new iPhone 12 and the latest Onyx Remote.

I’d activated the remote in the network settings in Onyx, set a password etc, but the remote cannot ‘see’ the PC. I’ve tried the windows firewall setting, but I can’t see what I’ve missed.

Can anyone give me any guidance? Should this combination be working?


Whats your IP addresses?


iPhone is similar also, both supported by DHCP.


I am having the same issue here. When I connect the pc with Onyx on it to a 192.168.0.x IP I can access remote however when I am trying to connect to another router with an IP of 10.0.0.x I cannot connect to the remote. Could this potentially be a router issue or an issue with remote in that range? Thanks

Hey guys, just checking in on this one again. I have tried everything from firewall settings on the computer to all security and firewall settings on the router but still no luck. Thanks

I had some progress by totally deactivating the Defender firewall, so it appears to be a port issue, but I don’t know which ports are used any what protocols to allow. Are the ports documented?


Hey All,

Not sure if you are aware, but one of the iOS updates added a network setting. If you ignored it or turned it off that might be your issues. You can try turning it on, or uninstall the app and reinstall it. It happened to me the first time. But I use the app weekly with no problem. So maybe check try checking the setting.

Hope this helps,


Thanks Watson. Is this in the Home Screen before connecting to an onyx show? I just deleted and reinstalled the remote however cannot see those settings anywhere. I am on onyx remote 2.7.0.

Thanks for the advice.

That setting is in the main iPhone setting area. There you will see the list of apps on the phone. Scroll done to ONYX. I am also on 2.7.0. I will also say I usually use it on an iPad so when using the remote on the phone, you need to make sure that cellular data is off and you are on the correct wifi.

Again hope this helps,


Hey guys thanks for all the help. Just a heads up I solved this with a couple of things. I switched off my 5ghz wifi and used 2.4ghz only which helped a lot with the speed of connection.

I also finally was able to view the show on my 10.x.x.x network by manually adding all the onyx binaries through my firewall. I am sure there is a specific one (potentially OnyxStageCommunicator.exe) which resolved it but I ended up adding everything to ensure no other issues. Not sure why they were not allowed by default however very happy that it’s working now.


I have just gone through again to validate exactly which binary you need to allow access to. It’s OnyxXNet.exe which you need to allow through the firewall for the remote to work.

1 Like