Submaster module LCDs acting weird with 4.6.1219

Hi all,

I recently updated Onyx from 4.4.1193 to 4.6.1219 (about time…) and I have an issue with my Submaster module (the wide grey one).

I read that others also had problems with it but mine is different :
The two LCDs for faders labelling are acting weird, they lose some of the cuelist names and sometimes don’t change at all between two banks. The rest of the functions are fine (faders, buttons, bank changes etc…) and the module does control the software perfectly, it is just the LCD labelling that is weird.
I tried restarting the module, it works fine for 2 minutes then act weird again. On the console tester the module is fully OK, and it worked perfectly with 4.4.1193.

Is there a known issue about that ?


No known issue, but weird that it starts failing after some time. Could this occur after having switched to specific bank(s), or …? If you maybe could share a short video showing what happens and PM me your show file, we could have a look.

Hi Gert,

I have also come across this strange little bug with 4.6.2020 and the submaster wing. I just haven’t had time to report it yet. My issue is the cuelist name disappears on all of the 6th fader LCD display. You can move the cuelist to the slider next to it and it reappears. I shall try and make a video for you and send you a copy of the show file. Has only started since I upgraded to the latest release.

SyIP which style submaster wing is it? Is it one of the older models with the USB DMX outputs and wibu key or the later version without the wibu key and DMX outputs?

Kind regards


Hi all,

My Sub module is the later version without the key and the DMX card.
I also have a MaxModule Programmer and a Playback II module connected, both equipped with the DMX card and Wibu key and those work fine.

Gert, in fact after re-trying it, it is not a matter of time, but a matter of bank change. Sometimes when the show starts, the LCDs are already weird, but other times they are fine and start failing after a bank change.

A little video here :

Hello, thanks for the report and sharing a show file, we detected a bug and it will be fixed in an upcoming build

Hi Gert, excellent ! That’s why we love Onyx :slight_smile:

Some update on a similar point :
I intensively used the desk the last 4 days just after updating to 4.6.1220
While the sub LCDs problem remained the same, I also had some problems with my modules that I did not experienced with the version 4.4.1193.

To clarify the situation, the USB and DMX connections are as follows in my desk :

Running that set-up, I encountered rare, but random and weird problems. The desk could run fine for an entire day, and the other day randomly lose the DMX outputs or make strange things, like no displays on any of the modules, the sub module faders not working, the LCD buttons of the prog module loosing their backlights, or the playback acting weird on the old black Maxxyz wings.

Most of the time, the situation could be saved by launching then closing the Console Tester, which resetted the connection between the modules and Onyx. That makes me think of a problem with the 4.6.1220 hardware drivers more than a hardware problem, but as my set-up is quite “exotic”, I assume it’s hard analyze…

Except for the DMX output, I expect the behavior is due to the same bug. Could you confirm by leaving out the Submaster Module? We’ll consider another maintenance build soon to include the fix

The DMX loss did happen but it was just one or two times over the 4 days. The main problem was in fact the bugs with the control panels. I noticed that the bugs often started while a key from the MaxModule Programmer and a key from the Submaster Module were simultaneously pressed (we were two operating the desk at the same time).

With this big show now finished, I have stocked the big desk away so it’s not easy to try things now, but if you include a fix in the upcoming build, I will then upgrade and try.

Please check again with build 4.6.1221