Install ERROR 27502

Get this error when trying to install the latest vers.

Udklip

Have you found a work around for this? Currently experiencing the same issue. Have tried connecting to 4 different networks, done a full removal, full windows updates, tried installing 3 different versions of the program and continue to get the same error. Any help would be amazing!

Nope still stuck :frowning:

Ive done everything on this thread still no luck

Im running win10 only with defender and same setup on my laptop and the laptop is working.

Everything is updated

Hey folks,

Not sure if this will be much help (I see that djnicklovin tried the first link), but here are a few posts to try:

This first link references the older version of the software (3.71 when it was still called MP-C)

This second link discusses maybe a missing ODBC connector and possible fix:

This third suggestion was basically a “reset” of the Windows 10 box (eek):

There are a few links outside of this forum, but not sure if it helps much:
https://social.technet.microsoft.com/Forums/en-US/59edc35c-82b3-47ef-86db-f9f89d2e5040/error-27502-cannot-connect-to-microsoft-sql-server?forum=sqlgetstarted

https://social.msdn.microsoft.com/Forums/sqlserver/en-US/f32c7eba-73a7-49bb-a2b1-501980e74667/error-27502?forum=sqlgetstarted

That’s about it. Apologies, hope one of these solutions helps.

Thanks,

James

Hi All

I fixed the issue by installing M-PC vers. 3.70 and then updated it.

Any new updates on this? I am having this problem on a Windows 8.1 machine. Error 27502. Seems to be related to “sqllocaldb” not working right. I even went to the extent of installing a version of Microsoft SQL Server 2017 on the machine, which was a total headache, broke the networking on the machine and took an hour of work to remove and restore the machine after that failed to fix the issue.

This seems like a pretty common problem. Is there any kind of practical way to overcome it?

FixLoginErrors.vbs (793 Bytes)
Could you run the attached script as administrator (easiest way is probably to start a command prompt as administrator to launch it)? If that doesn’t help, could we setup an AnyDesk session?

Keep in mind that 8.1 wont be supported any longer by ONYX.

Okay, so I figured out how to run that vbs from an “elevated” command prompt. I actually tried the sequence a few times. I hve attached a sequence of screenshots from the final attempt. As you can see the vbs script generated a message “Onyx not found. Removing stale database” and then “Succeeded, try installing Onyx”. The installation program (the beta) threw an error about not being able to create a show, and later about a script not being found. Finally failed.

Appreciate the help man.

If you browse to the %TEMP% folder in Windows Explorer (you can just enter it like that in the path bar), there’ll be several files whose name starts with MSI. You could sort them by time: could you send me the most recent one (assuming no other installers have run meanwhile: the text file should refer to “onyx.msi” in the first few lines)?
We may need an AnyDesk session, though.

Here are the last two files starting with MSI in the %TEMP% location. I’ve also attached a screenshot of the folder. I tried again a few times tonight, running the vbs script before each time. The final time, reflected by “MSIf5872.LOG” I tried installing only for the current user account, I didn’t try that before. (Xena is the administrator account anyway). No luck on any of these tries, it always throws the same error messages and the install fails.

The files were too big to upload on this forum, so here is a link to Google Drive. Hope it works.

https://drive.google.com/drive/folders/18cyrRhvE_tqUD0o4BE3IKh41_CsF5QJw?usp=sharing

I’d be happy to do a Anydesk session. Never done remote/

screen sharing before, but I could probably figure it out on my end.

Hmm, that’s a new one, but I suspect some leftover of a previous install.
Please download and run the utility from anydesk.com, and PM me the ID and password. What timezone are you in?

Copy will do. It will take me a couple days though, as I won’t be home much in the next two days. I am in the US Pacific Time Zone. I have Sunday and Monday off from work, so anytime those days are good. I also stay up fairly late at night frequently if that helps.

I was also wondering if something related to another program could be making the problem. I recall that I installed Reaper (audio production software) and some support apps since the last time I installed MPC or Onyx on that machine.

I’ve been looking at your system, trying some things manually, and I’m afraid Windows 10 is a hard requirement. Some new feature requires an API call that was introduced in Windows 10 and I wasn’t sure whether not running Windows 10 would only keep that feature from working, but my tests on your system showed the binary simply can’t be loaded due to that (and the binary is being used during the installation already).
Now I’ll need to find an alternative way for the installer to detect it’s not running on Windows 10 and block right away with an appropriate message, because the standard way can’t differentiate between Windows 8.1 and Windows 10 :frowning:

I appreciate that. I’ll leave the Anydesk app up.

-Steele

I guess that upgrading to Windows 10 is an option for this machine. I hadn’t really wanted to do that. However if it’s between that and buying another computer it might force my hand. From what I understand it’s still possible to get W10 for free, although it’s kind of unclear what the status is.

Try https://www.theverge.com/2020/1/14/21065140/how-to-upgrade-microsoft-windows-7-10-free-os