Onyx RC 4.9.1254

Hi Everyone,

This build requires OS 4.9 on consoles.

As always, please keep all discussions and comments about this beta to THIS forum post.

Have a good weekend and happy testing!!

Download: (Replaced with ONYX RC 4.9.1255)

4.9.1254 (02/08/2023)


Telnet and UDP commands currently supported: CLRCLR, GQL, RQL, PQL, GTQ, RAO, RAQLDF, RAQLODF, RAQLO, RAQL, SQL

Improved consistency between various beat inputs and states

Improved grouping manipulation (changing the selection mask or its parameter)

Fixed Follow and Wait cues not working correctly on secondary systems

Fixed motorized fader crosstalk from virtual panel on different ID and bank

Fixed 2D Shapes (like Bouncing 2D Shapes) not working (showing white canvas) on some nVidia-based systems, as well as mask blending on some unspecified systems

Fixed click track beat detection

Hi to all!
Everytime I change the “STEP” , i think this happens also touching other parameters on the NORMAL FX engine, is that has the “COMBO OFF” that is the selected and needed one , changes to "ON " again.
Looks like Onyx reselects and activates the “COMBO” , so I need to reselect it and correct it to “OFF”.
Can you check it out please!

Scrolling causes visual glitches, while cuelists are playing back in cuelist directory.
Selection (Red tile) isn’t displayed either, when glitch is active.

View: 2D Plan, Dylos Zones, cuelist directory

Beat button on M-Touch has the Chase outlined when the button is pressed, giving the illusion that it works on the computer but it doesn’t do the same on the networked comptuer. Hitting the Play button in the chase still seems to work. Maybe I need to reassign it to global before the beat button works again. But there are certainly issues with the tap of the beat button and synchronization between two computers.

added 8/20
Couldn’t delete multi-part fixtures from the patch. Then when I imported a fixture the fixtures I was trying to delete disappeared and so were deleted.

@mgerardi @gert_leunen
commend added 8/26

It seems like this update introduced issues which worked fine in the previous beta. For example, when recording a cuelist to the main playback bar it doesn’t show the other cuelists steps as having been recorded until play the cuelist.

Not sure if this issue was there before but Onyx freezes when I try to add a generic multipart RBG Pixel , for example the 100 cell Pixel, to the 2D plan in Dylos stops Onyx from working.

Also a custom fixture I edited for a pixel strip doesn’t respond to the intensity levels of cuelists or inhibitives. I can only record the cuelist at a set level or use the live programmer to change the intensity level.

Was reminded that the change in licensing to a one universe of Artnet output to the Capture visualizer affects the demo show file, as only the first universe of output works. New users who want to demo Onyx won’t have a USB license key or other hardware unlocking the second universe of Artnet output.

9/3, noticed that when applying the Intensity FX it stops the strobe from working.

9/9 Can’t renumber cuelists (in the Cuelist Values window with Edit enabled).

I get something close on NX1, but “different”.

It is on presets, sometime I lost all the visu of my preset (beam fx tab as example). I need to restart the NX1 to see them again (the scroll doesn’t do anything I see empty list of preset, but if I try to record other, I have the classical command to merge/replace etc… So it’s really seems to be a graphical issue somewhere.

It has also happen to me with virtual playback, but this only happened once in 1253, not 1254.

Is the NX1 compatible with BPM effect with dylos? I can’t see anything in the Source Sync library

I can’t even set the “old” BPM system on a classical chase, don’t have any input processor available.

While on PC all is fine

started a new showfile on windows 11 with 4.9.1254 and the pulse mode on a tap sync (Beat Display) doesnt work anymore… Its just a blank output

I had a weird effect with the MataBalls where they were glitching outin a constant way… I installed new graphics driver and restarted Onyx and it worked Fine

Maybe its because I started a new showfile and enabled Dylos the first time I lunched and created the project

trying (period) (enter) on the popout keypad doesn’t select all fixtures in the programmer after going next/ last.

For me, it works as it was working before, nothing new (. enter reload fixture which has something in the programmer).

To reselect all your selection, simply press “Last” & “Next” in the same time.

Hi to all on the 1254 BETA VERSION
Everytime I ,copy or move or delete a processor,the windows clears all selected layers or whatever items where active!
Cause in this way we always need to start again. Thanx to all!

I’ve installed the beta on another NX1, and get the same issue.

Am I the only one to have this issue? Could it comes from a bad iso download (I don’t think, but…)

So when in the HIGHLIGHT window, and I am using the “Last or Next” on keypad, everything is ok, when using the keyboard shortcuts like " CTRL +PG up or down " I can see some weird graphic glitches in the window ,when moving to the next fixture,when going in PREVIOUS nothing strange.
Thanx to all. = )

I guess this is a show file you created on PC and try to load into NX1? You can add input processors on the NX1?

Tnx for the report, looks like the screen navigation doesn’t monitor the state of the Ctrl-button when page up/down is being pressed, causing double action. Will be fixed in next build

That’s because the processors are also fixtures and, as for fixtures operations while in patch mode, the caches must be rebuilt to update references. This will be improved in a future version.

Yes, that’s a PC show file created on v4.9.1249 if my memory is correct.

Is there any documentation (yet) explaining how to add input processor please?

I’ve tried to find it without success =(

Simply double click or right click on an (empty) slot and a wizard will pop up where you can select. AFAIK, documentation is in progress (it takes until release candidates for new features and their visuals to be stable enough to start documenting)
Maybe there’s a issue with the show file if it shows input processors on a PC, but not on an NX1, maybe you could upload it to Obsidian Control Systems so we could have a look (because it appears to work on our test).

1 Like

Overwrite Q Blender doesn’t update Cue count in cuelist directory correctly.
(picture example: 2 Cues in the cuelist but cuelist directory shows 3 cues.)
I haven’t found an update pattern yet.

In the settings in I/O to select the microphone for audio input.

I’ve used the Dylos > Input tab to double click on an empty space and that opens a popup window.

Although I’m not sure how to delete sources.

1 Like